Forum Topic: wordpress multisite: problems with inside page links

Forum: .htaccess Forum : WordPress • Posted by Giovanni Aniello • Updated:

Hi,

I've installed wp ms 3.5 for a multilingual site with multidomain option selected. I'm using multilingual press plugin for translating different pages, that works well enough.

The problem is that for classifying my materials I've done a index page with many issues (titles), each of them is linked to another page that explain deeper the matter.

The italian and french version of my site give me no problem, but english version is very orginal: when I link the title to the page the result is :

No Results Found

The page you requested could not be found. Try refining your search, or use the navigation above to locate the post.

If I look at the url I notice that every time the permalink is the correct url+%E2%80%8E

I've set custom permalink /%category%/%postname%/%post_id%

Setting permalinks on default,that is http://en.namesite.eu/?p=123, the links drive to home page. French and italian version go as well.

Just for giving all informations: the url that the link opens is not changed after I've set permalinks on default, that is correct url+%E2%80%8E/. In this case I have not "no result found" but the home page appears

What would you do if you were me?

thanks a lot

2 Replies to “wordpress multisite: problems with inside page …”

Jeff Starr
Posted by Jeff Starr

Hi Giovanni,

It sounds like the translation plugin is interfering.. if your site works properly when the plugin is disabled, I would contact the plugin support team and see if they can help. They should be able to help, and if not I would look at trying some other translation plugins, services, and/or tools (there are many available these days) to see if they work better.

Good luck!

Posted by Giovanni Aniello •

Thank you!